Browse window from V6 to V9  
Author Message
rcir88





PostPosted: Sun Apr 01 19:06:48 CDT 2007 Top

Exchange Servers >> Browse window from V6 to V9

I just updated and very happy.
However, I rebuilt my project in V9 and ran the .exe in another directory.
The first time I go to open a browse window I get "Invalid Browse Setup --
Default Setup Used" and everything runs fine after that. But I think I'm
missing something new about the browse window.
I found SET REPORTBEHAVIOR 90 and the reports work great.
Is there a setting I can't find for the browse windows.
I can't have my customers seeing the popup "Invalid Browse Setup" LOL

Exchange Server8  
 
 
Dan





PostPosted: Sun Apr 01 19:06:48 CDT 2007 Top

Exchange Servers >> Browse window from V6 to V9 "Invalid browse setup" comes from the foxuser.dbf/fpt resource file. They've
never been particularly cross-version friendly.

If you are distributing your Foxuser, of course, your users won't see that
message because they will have the new version you distribute.

If you are using Foxuser by accident in the first place, well, maybe you
should investigate what they are and how they work.

Dan




>I just updated and very happy.
> However, I rebuilt my project in V9 and ran the .exe in another directory.
> The first time I go to open a browse window I get "Invalid Browse Setup --
> Default Setup Used" and everything runs fine after that. But I think I'm
> missing something new about the browse window.
> I found SET REPORTBEHAVIOR 90 and the reports work great.
> Is there a setting I can't find for the browse windows.
> I can't have my customers seeing the popup "Invalid Browse Setup" LOL
>


 
 
Loren





PostPosted: Mon Apr 02 19:56:03 CDT 2007 Top

Exchange Servers >> Browse window from V6 to V9 Thanks Dan,
You said "foxuser.dbf resource file" and bingo ! It hit me.
I copied all my old files to a new directory for VFP9 to use.
I have copied V6 resource file to that directory.
Thanks that was the wake up.



> "Invalid browse setup" comes from the foxuser.dbf/fpt resource file. They've
> never been particularly cross-version friendly.
>
> If you are distributing your Foxuser, of course, your users won't see that
> message because they will have the new version you distribute.
>
> If you are using Foxuser by accident in the first place, well, maybe you
> should investigate what they are and how they work.
>
> Dan
>
>


> >I just updated and very happy.
> > However, I rebuilt my project in V9 and ran the .exe in another directory.
> > The first time I go to open a browse window I get "Invalid Browse Setup --
> > Default Setup Used" and everything runs fine after that. But I think I'm
> > missing something new about the browse window.
> > I found SET REPORTBEHAVIOR 90 and the reports work great.
> > Is there a setting I can't find for the browse windows.
> > I can't have my customers seeing the popup "Invalid Browse Setup" LOL
> >
>
>
>